file MiddleStates 7.2 bug reports

More
14 years 5 months ago #18445 by GrandpaTrout
Please post bug reports here. Especially crashing bugs. Also report an issues or errors you find in the install (or other) documentation.

Please Log in or Create an account to join the conversation.

More
14 years 5 months ago #13018 by cavhog
Replied by cavhog on topic MiddleStates 7.2 bug reports
Random error that pops up now and then. Can't seem to isolate the trigger. Will periodically give me the "No UniGUI subscreens available" error and will have to restart the game.

Once more into the breach...

Once more into the breach...

Please Log in or Create an account to join the conversation.

More
14 years 5 months ago #13020 by GrandpaTrout
Ok. I have seen that bug once. But I thought it was just a development issue. I will take another look through the UniGUI code. And perhaps add more debug information, as having no subscreens is never going to happen in Epic.

Please Log in or Create an account to join the conversation.

More
14 years 5 months ago #13026 by GrandpaTrout
Here is some ammunition for you bug hunters. One of the critial weaknesses of modding EoC is the lack of save game support. The game was only meant to be saved from inside the base.

If you want to break things, try saving outside the base and restoring. Then try saving inside the base and restoring.

Look for properties that the game should be saving: Wingmen, fuel, money, cargo. Try different restores and discover if they survive the save/restore cycle. I am sure I have missed some combinations.

Another weakness is the code path for a load is different that the code path for entering the base and launching again without saving (why did they do this!!!) so that tends to break things.



Please Log in or Create an account to join the conversation.

More
14 years 5 months ago #13035 by cambragol
I caught a bug related to an older file. The version of planets.ini included with the 7.2 release is not synched with the new planet textures. I have sent the correct planet.ini file out to everyone attached to an email. Just drop it into your MS_Mod_Geog file, overwrite and all the planets will be displaying and sorting correctly.

Please Log in or Create an account to join the conversation.

More
14 years 5 months ago #13036 by cambragol
Here is something. I hired the 'For Hire' transport. Then I flew around the system a bit. The transport remained where I had hired it. When I returned another transport with the exact same name was generated over top of my old transport. They were fused so to speak. Can we randomize the placement of pog objects so that when we return to a station this does not happen, or at least there is some change in the appearence of the station? Otherwise, it might get a bit tiresome, after each loop of a trade route, to see the same old freighter or whatnot sitting in the exact same position as always. Some kind of randomization to the placement of these 'pog objects' would do a lot.

Please Log in or Create an account to join the conversation.