file The Steam AND the GoG Version does not work

More
3 months 3 weeks ago #20818 by BarFly
Hello,

i'm the same BarFly which started that Thread about getting the Joyhat (Coolie) to strafe instead of switching hud.
i-war2.com/forum/technical/3253-change-strafing-to-coolie-hat
now i have the Problem that after changing my Computer to a Ryzen 3700X, AMD 5700XT, SSD, Samsung 32" WQHD Curved monitor and a new Thrustmaster T.16000 plus TWSC Throttle + Recaro Seat ;-)) IWar EoC neither from Steam nor from GoG is working as it was before i.e. when i started the mentioned thread.
Both -Steam AND Gog behave similar
Funny thing - IWar 1 seems to work as expected
Ok:
Starting IWar EoC - > the movies are all fine, but then when it switches to the game menu, i just see 'Instant Action' and 'Credits' . There is no mouse pointer to see. Playing around with 'ESC' key, 'Tab' and the Arrow keys i see' oad game' for a short moment or some empty boxes.
I managed to start a new Game, the Joystick is working, the throttle not, but there is no Hud to see, no chance to switch, for example, to the contact list.
I also tried different screen resolutions down to 800 x 600 :-)
Does anyone has an idea how to solve that problem? I'm out of ideas and my knowledge about the Game is not really deep.
Here is the flux.log

File Attachment:

File Name: flux_log.txt
File Size:37 KB
[/sub]

Ciao Hans
Attachments:

Please Log in or Create an account to join the conversation.

More
3 months 3 weeks ago #20819 by RavenZahadoom
This sounds like the old no CD or DVD drive problem. You need a CD or DVD drive for single player to work; doesn't have to be real, it can be an emulated one, many free options available, just search online.

Please Log in or Create an account to join the conversation.

More
3 months 3 weeks ago - 3 months 3 weeks ago #20820 by BarFly
Hello,

thanks for the advice, but that is not the solution.
I have a USB Bluray player connected and a virtual DVD Rom.

Maybe this files will help for somebody who has an idea:

File Attachment:

File Name: flux_ini.txt
File Size:10 KB


File Attachment:

File Name: defaults_ini.txt
File Size:10 KB
Attachments:

Please Log in or Create an account to join the conversation.

More
3 months 3 weeks ago #20821 by RavenZahadoom
My bad, I think I got mixed up with Tron 2.0 which I also recently replayed now I'm thinking that one had the drive problem.

Sorry could not be of more help.

The only other thing that comes to mind is updating direct X? Win 10 doesn't come with dx9 as standard does it? you might need to install DX9 (which supports DX6 to 9 actually because I war 2 uses DX7 or 8 right. Although I guess you could get an error message if the right DX was not present.

Please Log in or Create an account to join the conversation.

More
3 months 3 weeks ago #20822 by BarFly
Hello,

it looks like you are not quite wrong.
I did some more research and found that, from @ Schmatzler at the Steam forums:

The game only needs to see a D: drive to show up the SinglePlayer option. Mount any ISO file you can find and you're done.

Does it really need a optical drive at 'D'? my Bluray player is 'H' and my virtual optical drive is at 'I'
'D' is a SSD drive with 1TB. I have my Steam and my Gog and my Uplay Games at that. And when i played that game 3 years ago it run smooth. It was also Win10 64bit and it was also running with drive 'D', then as a HDD.
I will test my old monitor with 1920x1080 just HD and also my Joystick i used.

Ciao Hans

Please Log in or Create an account to join the conversation.

More
3 months 3 weeks ago #20823 by RavenZahadoom
No, I use a virtual drive and it's at 'N' (I have many drives on my machine, don't ask long story), so it should be ok. If you have a virtual drive at 'I' it should be ok, in fact I just checked I don't even have anything mounted and it's working fine. But I do have win 7, this could be a different win 10 issue. Also, I know you said you have both versions but mine is the steam version for reference.

Please Log in or Create an account to join the conversation.