file Modifying default ship.ini's

More
2 years 11 months ago #20391 by ataraiym
I read the modding primer and the info on the player default tug .ini and changed a few things, nothing major just speed and tweaked the manouverability and hitpoints / armour by 10%, as if wothisface had done it, but far as I can see it's changed nothing.

Max speed is still 850 mps. No way of telling if the armour has changed as no readout that I can see.

I changed first the escapetug.ini as per the primer and when that didn't seem to work matched all the other instances of player_tug I could find.

Still the same.

Yes changed "read only" and saved as normal.

What have I missed?

!(>..<)!

Please Log in or Create an account to join the conversation.

More
2 years 11 months ago #20393 by Chessking
Well, escapetug.ini should only modify the tug used right when you escape from the prison camp. That tug had a normal crew module, instead of the Advanced ComSec, and predefined weapons, so it got its own .ini file. Ironduke should be better able to help you.

This is one tough navy, boy. They don't give you time off, even for being dead. -Clay

Storm Petrel

Please Log in or Create an account to join the conversation.

More
2 years 11 months ago #20395 by IronDuke
Are you changing the files directly in the resource.zip, or are you copying them to a mod folder first? There's also a resource folder that makes things odd.
If you're copying them to a mod folder, which is what you should be doing, then you have to enable the mod in the "Extras" section of the main menu. If you're changing them directly in resource.zip, that's a bad idea, as it not only deprives you of the originals, but it can cause issues with version of Windows newer than XP.

The resource folder exists for this reason: the game looks for files in a specific order. First, folder. Next, a .zip. Next, a CD. Then it gives up. This means that anything in the resource folder has precedence over anything in resource.zip. This is handy for the developers, since they made the F14.6 patch simply plop changed/fixed files into a folder. The problem is that if you change a file in the .zip (which I still don't recommend) the changed are ignored if the file is in the resource folder as well.

Now, if all my talk of mod folders and resource folders made you like this guy --> :? then you probably don't have the game patch installed. If you don't, it's right here .

Now, if you've done all that, here's what's needed to mod the tug. Create a folder in the game's mod folder, and call it "Super Tug" or whatever the heck you like as long as you'll know what it means. :P Create these folders: sims; ships, put ships in sims; player, put player in ships. Now open resource.zip, go to sims/ships/player and copy the tug.ini file. That's the one for regular gameplay. As Chessking pointed out, escape_tug.ini is for the tug version used when you prison bust. tug_prefitted is the Instant Action version. What you want is to copy that tug.ini file into the "(your mod name)/sims/ships/player" directory you've created. Remove read only, and go crazy. When you're done, fire up the game, go into "Extras" in the main menu, and your mod should be listed. Simply turn it on, and yay. :cheer:

Hope this helps!
--IronDuke

I-War 2 Discord: discord.gg/RWaabWB
Very little about the game is not known to me. Any questions you got, throw them at me. :)

Please Log in or Create an account to join the conversation.

More
2 years 11 months ago #20396 by ataraiym
Thanks for the reply Iron, I'll give that a try and see.

!(>..<)!

Please Log in or Create an account to join the conversation.

More
2 years 11 months ago - 2 years 11 months ago #20397 by ataraiym
hmm ok - well still no dice. What I have is a new folder in mods called "super tug"

inside that I have sims > ships > player > tug.ini

Just tried playing again and ship speed still 850 - and 3 marauder corvettes approaching L point nailed me with missiles before I could hardly move. I'd been there maybe 5 minutes.

I reset all other instances of tug.ini and escape tug.ini (just deleted my copies and reinstated backups)

Either I didn't follow the instructions properly or there's something else I've missed.

edit:
I've just checked the log and found this:

IMOD: [unknown] No descriptor file "Super tug.ini" for mod "Super tug"
IMOD: [unknown] Mod display_name = "Super tug"
IMOD: [unknown] No scenario package available

I've renamed tug.ini to supertug.ini and changed the name in the header info too but still no change.

!(>..<)!

Please Log in or Create an account to join the conversation.

More
2 years 11 months ago #20398 by IronDuke
You did turn on the mod in the "extras" menu, right?
If so, attach the mod folder and I'll try it on my end.

--IronDuke

I-War 2 Discord: discord.gg/RWaabWB
Very little about the game is not known to me. Any questions you got, throw them at me. :)

Please Log in or Create an account to join the conversation.